Payment Processor Experiencing Issues
Incident Report for Paperspace
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 06, 2019 - 16:24 EDT
Monitoring
We are advised that our payment provider is experiencing issues. VAT ID validation and tax information will not be available. We are closely monitoring this and will update this incident when they have resumed service.
Posted 3 months ago. Aug 06, 2019 - 15:46 EDT