Payment Processor experiencing disruption
Incident Report for Paperspace
Resolved
Our payment processor reports the issue has been resolved.
Posted Jul 10, 2019 - 19:42 EDT
Monitoring
Our payment processor has reported a service disruption that may result in Paperspace users being unable to add or updated their payment methods, or experience errors when making a payment. We are following their updates and will update our status page accordingly as more information becomes available.
Posted Jul 10, 2019 - 18:15 EDT
This incident affected: Console.