Payment processor experiencing disruption
Incident Report for Paperspace
Resolved
This incident has been resolved by our payment processor, and users should not have any issues processing payments on Paperspace.
Posted 3 months ago. Feb 06, 2019 - 11:40 EST
Monitoring
Our payment processor has reported a service disruption that may result in Paperspace users being unable to add or updated their payment methods, or experience errors when making a payment. We are following their updates and will update our status page accordingly as more information becomes available.
Posted 3 months ago. Feb 06, 2019 - 10:29 EST